Equities, Options, and Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Aug 31, 2020 - 08:50 PDT
Update
Some users are experiencing issues with delayed order status updates. These are display issues only, and should not impact order execution. We are working to resolve this as soon as possible.
Posted Aug 31, 2020 - 06:57 PDT
Investigating
We are experiencing issues with equities, options, and crypto trading. We are working to resolve this as soon as possible.
Posted Aug 31, 2020 - 06:38 PDT
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading, Fractional Equities Trading) and Order Status Updates.