Cryptocurrency trading is currently down.
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 3 months ago. Oct 29, 2018 - 19:50 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Oct 29, 2018 - 19:36 PDT
This incident affected: Trading (Crypto Trading).