System Maintenance
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 05, 2018 - 16:45 PST
Identified
Our systems are currently undergoing scheduled maintenance. We'll keep you posted on when we expect service to be completely restored, and every half hour as well.
Posted 10 months ago. Nov 05, 2018 - 16:13 PST
This incident affected: Overall System (Overall System).