Delayed Email Support
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 7 months ago. Aug 17, 2018 - 12:38 PDT
Monitoring
We believe this issue has been resolved and are monitoring the fix to confirm.
Posted 7 months ago. Aug 17, 2018 - 11:30 PDT
Investigating
We are currently investigating an issue that is causing an abnormally high number of emails from customers to be marked as spam. Because of this issue, we are taking longer than normal to respond your inquiries. We appreciate your patience and will provide an update when this issue has been resolved.
Posted 7 months ago. Aug 17, 2018 - 08:49 PDT
This incident affected: Email Support.