Incorrect Account Balances
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 2 months ago. Nov 24, 2018 - 08:05 PST
Monitoring
We have implemented a fix and are monitoring. You should now see the correct balance in your account.
Posted 2 months ago. Nov 23, 2018 - 21:28 PST
Identified
We have identified an issue which is causing account balances to display incorrect values. We expect this to be resolved in the next 60 minutes.
Posted 2 months ago. Nov 23, 2018 - 19:53 PST
This incident affected: Overall System (Overall System).