Cryptocurrency trading is currently down.
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 07, 2018 - 20:22 PST
Investigating
We are currently investigating this issue.
Posted 10 months ago. Nov 07, 2018 - 20:05 PST
This incident affected: Trading (Crypto Trading).