Crypto Web Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 08:07 PST
Investigating
We are experiencing issues with crypto trading on web. We are working to resolve this issue as soon as possible.

1028798
Posted Dec 05, 2019 - 07:03 PST
This incident affected: Apps (Web App) and Trading (Crypto Trading).