Web App Outage
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 29, 2019 - 11:51 PST
Update
We are continuing to work on a fix for this issue.
Posted 7 months ago. Jan 29, 2019 - 11:51 PST
Identified
We are currently investigating this issue.
Posted 7 months ago. Jan 29, 2019 - 11:37 PST
This incident affected: Apps (Web App).