Options Market Data Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Feb 06, 2020 - 07:13 PST
Monitoring
Some customers are experiencing issues with delayed or incorrect market data for options chains in the range of TNA to UPRNZ. Our third party market data provider is working to resolve this issue as soon as possible.

1082142
Posted Feb 06, 2020 - 06:30 PST
This incident affected: Market Data.