Order Health
Incident Report for Robinhood
Resolved
We want you to know we have resolved this issue. New orders and transfers will now process correctly. We recommend you log out and log back in to refresh your account.
Posted almost 2 years ago. May 01, 2017 - 10:03 PDT
Identified
We are experiencing an issue that is affecting orders. We are aware of this issue and have all hands on deck working to resolve it as soon as possible. Please check back here for real-time updates.
Posted almost 2 years ago. May 01, 2017 - 09:49 PDT