Crypto Trading Issue
Incident Report for Robinhood
Resolved
The issue has been resolved.
Posted 5 months ago. May 02, 2019 - 18:16 PDT
Investigating
We're experiencing issues with crypto order execution. We are working to resolve this issue as soon as possible.
Posted 5 months ago. May 02, 2019 - 18:09 PDT
This incident affected: Trading (Crypto Trading).