Order Status
Incident Report for Robinhood
Resolved
We want you to know we have resolved this issue. New orders will now process correctly. We recommend you log out and log back in to refresh your account.
Posted almost 2 years ago. May 31, 2017 - 08:47 PDT
Investigating
We are experiencing an issue this morning that is affecting order confirmations. We are aware of this issue and have all hands on deck working to resolve it as soon as possible
Posted almost 2 years ago. May 31, 2017 - 08:05 PDT