Cryptocurrency trading is currently halted
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 5 months ago. Oct 09, 2018 - 13:33 PDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. Oct 09, 2018 - 13:18 PDT