Degraded Options Market Data
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 5 months ago. Oct 26, 2018 - 07:46 PDT
Update
We are continuing to investigate this issue.
Posted 5 months ago. Oct 26, 2018 - 07:46 PDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. Oct 26, 2018 - 07:20 PDT
This incident affected: Market Data.