ACH Transfers and Bank Linking Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 4 months ago. Oct 09, 2018 - 09:34 PDT
Update
We are continuing to investigate this issue.
Posted 4 months ago. Oct 09, 2018 - 09:32 PDT
Investigating
We are currently investigating this issue.
Posted 4 months ago. Oct 09, 2018 - 09:30 PDT