Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 08:52 PST
Investigating
We are experiencing issues with crypto trading. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted Nov 14, 2019 - 08:36 PST
This incident affected: Trading (Crypto Trading).