Crypto Order Cancellation Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 4 months ago. Sep 28, 2018 - 08:18 PDT
Investigating
We are currently investigating this issue.
Posted 4 months ago. Sep 28, 2018 - 07:32 PDT
This incident affected: Trading (Crypto Trading).