Systemwide Functionality Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 16 days ago. Oct 02, 2019 - 08:46 PDT
Investigating
We are experiencing systemwide functionality issues that may be affecting bank transfers, bank linking, and account maintenance. We are working to resolve this issue as soon as possible.

969514
Posted 16 days ago. Oct 02, 2019 - 07:21 PDT
This incident affected: Overall System (Overall System).