Portfolio Delays
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 22:10 PDT
Update
We are continuing to investigate this issue.
Posted Oct 22, 2019 - 22:09 PDT
Investigating
Some users are experiencing delays loading their portfolios. We are working to resolve this issue as soon as possible.

20190910-948880-2859913
Posted Oct 22, 2019 - 20:45 PDT
This incident affected: Apps (iOS App, Web App, Android App).