Error at login attempt
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 7 months ago. Nov 02, 2018 - 13:40 PDT
Investigating
Some users may be experiencing issues logging in. We are aware of the issue and investigating a fix. We'll update this page every half hour, if not sooner.
Posted 7 months ago. Nov 02, 2018 - 12:43 PDT
This incident affected: Apps (iOS App, Web App, Android App).