Login Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jan 16, 2020 - 06:57 PST
Investigating
Some users are experiencing issues logging in on mobile and web. We are working to resolve this as soon as possible.

1060572
Posted Jan 16, 2020 - 06:49 PST
This incident affected: Apps (iOS App, Web App, Android App).