Order Status Update Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Dec 06, 2019 - 07:03 PST
Investigating
Some users are experiencing issues with order status updates. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted Dec 06, 2019 - 06:52 PST
This incident affected: Order Status Updates.