Service Disruption
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Dec 07, 2020 - 07:05 PST
Investigating
We're experiencing a disruption in service. We're investigating, and working to resolve this as soon as possible.
Posted Dec 07, 2020 - 06:39 PST
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading, Fractional Equities Trading), Apps (iOS App, Web App, Android App), Overall System (Overall System), and Market Data, Order Status Updates, Bank Linking, Bank Transfers.