Update on delayed crypto notifications and buying power
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 00:10 PST
Identified
Please note that funds from cryptocurrency sales are currently taking longer than usual to be reflected in buying power. Notifications for cryptocurrency transactions may also be delayed.

We are actively working on resolving this issue and appreciate your patience.

1420987
Posted Nov 19, 2020 - 22:34 PST
This incident affected: Trading (Crypto Trading) and Order Status Updates.