Options Trading on Web and Android
Incident Report for
Robinhood
Resolved
This incident has been resolved.
Posted
Oct
01
,
2020
-
11:24
PDT
Update
Some customers are experiencing issues viewing the options trading button on Web. We are working to resolve this as soon as possible.
Posted
Oct
01
,
2020
-
11:12
PDT
Investigating
Some customers are experiencing issues viewing the options trading button on Web and Android. We are working to resolve this as soon as possible.
Posted
Oct
01
,
2020
-
10:05
PDT
This incident affected: Apps (Web App, Android App).
×
Subscribe to Incident
Subscribe to updates for
Options Trading on Web and Android
via . You'll receive .