Crypto Halted
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jun 28, 2019 - 15:38 PDT
Update
Crypto trading is halted for maintenance.
20190628-887725-2671446
Posted Jun 28, 2019 - 15:20 PDT
Investigating
Crypto trading is halted during the maintenance window until 6:05 p.m. EST.

20190628-887717-2671421
Posted Jun 28, 2019 - 14:57 PDT
This incident affected: Trading (Crypto Trading).