New Application and Login Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 18:41 PDT
Investigating
Some users are experiencing issues submitting new applications or logging in to their existing accounts. We are working to resolve these issues as soon as possible.

992216
Posted Oct 23, 2019 - 18:34 PDT
This incident affected: Overall System (Overall System).