System-Wide Outage
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Mar 02, 2020 - 23:13 PST
Update
We are still experiencing system-wide issues. We are continuing to work on resolving this and will provide updates as they become available. All of us at Robinhood are working as hard as we can to resume service.
Posted Mar 02, 2020 - 12:40 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 02, 2020 - 08:18 PST
Investigating
We are experiencing a system-wide outage. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted Mar 02, 2020 - 06:38 PST
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading), Overall System (Overall System), Apps (iOS App, Web App, Android App), and Order Status Updates, Bank Linking, Bank Transfers.