Bank Transfer Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 12 days ago. Sep 06, 2019 - 16:01 PDT
Identified
Some users are experiencing issues with bank transfers. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted 12 days ago. Sep 06, 2019 - 07:24 PDT
Investigating
Some users are experiencing issues with bank transfers. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted 12 days ago. Sep 06, 2019 - 05:44 PDT
This incident affected: Bank Transfers.