Account Unavailable After Options Trading
Incident Report for Robinhood
Resolved
This issue has been resolved and all affected accounts have been restored.
Posted 7 months ago. Dec 13, 2018 - 17:37 PST
Monitoring
We have been working overnight to restore access to accounts and options trading. Nearly all accounts have been restored and we are working hard to finish this for everyone affected. We continue to appreciate your patience and understanding.
Posted 7 months ago. Dec 13, 2018 - 06:09 PST
This incident affected: Overall System (Overall System).