System Latency
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 31, 2019 - 07:02 PST
Investigating
We are currently investigating this issue.
Posted 5 months ago. Jan 31, 2019 - 06:35 PST
This incident affected: Overall System (Overall System).