Instruments Untradable
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted almost 2 years ago. Mar 15, 2017 - 09:22 PDT
Identified
We are experiencing an issue this morning that is affecting the tradability of some securities. We are aware of this issue and have all hands on deck working to resolve it as soon as possible.
Posted almost 2 years ago. Mar 15, 2017 - 07:25 PDT