Email Support Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Mar 04, 2020 - 04:48 PST
Investigating
We are experiencing issues receiving emails through our email support system. We are working to resolve this issue as soon as possible. In the meantime, please use https://robinhood.com/contact as the best way to reach us.
Posted Mar 02, 2020 - 18:16 PST
This incident affected: Email Support.