Reduced Buying Power
Incident Report for
Robinhood
Resolved
This incident has been resolved.
Posted
Sep
19
,
2019
-
05:34
PDT
Investigating
Some users are experiencing issues with reduced buying power. We are working to resolve this issue as soon as possible.
20190918-956456-2882019
Posted
Sep
18
,
2019
-
07:15
PDT
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading).
×
Subscribe to Incident
Subscribe to updates for
Reduced Buying Power
via .