Crypto Maintenance
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jan 12, 2021 - 17:08 PST
Investigating
We're upgrading our systems to make the Crypto experience even better, so cryptocurrency trades won't execute right now.
Posted Jan 12, 2021 - 17:02 PST
This incident affected: Trading (Crypto Trading).