Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Apr 15, 2021 - 20:38 PDT
Update
We are continuing to investigate this issue.
Posted Apr 15, 2021 - 19:50 PDT
Update
We are continuing to investigate this issue.
Posted Apr 15, 2021 - 19:17 PDT
Update
We are continuing to investigate this issue.
Posted Apr 15, 2021 - 18:58 PDT
Investigating
We are experiencing issues with crypto trading. We are working to resolve this as soon as possible.
Posted Apr 15, 2021 - 18:49 PDT
This incident affected: Trading (Crypto Trading) and Bank Linking.