Bank Transfer Issues
Incident Report for
Robinhood
Resolved
This incident has been resolved.
Posted
Nov
20
,
2020
-
11:30
PST
Investigating
Some customers are reporting issues with bank transfers. We are working to resolve this as soon as possible.
Posted
Nov
20
,
2020
-
07:39
PST
This incident affected: Bank Transfers.
×
Subscribe to Incident
Subscribe to updates for
Bank Transfer Issues
via . You'll receive .