Market Data Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 7 days ago. Sep 11, 2019 - 07:59 PDT
Investigating
Some users are experiencing issues with delayed or incorrect market data. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted 7 days ago. Sep 11, 2019 - 07:18 PDT
This incident affected: Market Data.