Crypto Trading Issue

Incident Report for Robinhood

Resolved

This incident has been resolved.
Posted Jan 27, 2021 - 07:30 PST

Investigating

We are experiencing issues with crypto trading. We are working to resolve this as soon as possible.
Posted Jan 27, 2021 - 06:49 PST