New Applications and Profile Settings
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jul 15, 2021 - 18:04 PDT
Investigating
We’re experiencing an issue affecting new account application submissions and profile updates in the app. We’re working to resolve this as soon as possible.
Posted Jul 15, 2021 - 17:40 PDT
This incident affected: Apps (iOS App, Web App, Android App) and New Applications.