Crypto Maintenance
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 19:54 PDT
Monitoring
We're upgrading our systems to make the Crypto experience even better, so cryptocurrency trades won't execute right now.

1061471
Posted Sep 30, 2020 - 19:45 PDT
This incident affected: Trading (Crypto Trading).