BSV Orders Not Executing
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 14, 2019 - 08:23 PST
Identified
We're experiencing issues with degraded BSV order execution. We are working to resolve this issue as soon as possible.
Posted 7 months ago. Feb 14, 2019 - 08:16 PST
This incident affected: Trading (Crypto Trading).