Market Data Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 13 days ago. Jun 11, 2019 - 06:49 PDT
Identified
Some users are seeing delayed or incorrect market data. We are working to resolve this issue as soon as possible.
Posted 13 days ago. Jun 11, 2019 - 06:42 PDT
This incident affected: Market Data.