Crypto Maintenance
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 01:37 PST
Monitoring
We're upgrading our systems to make the Crypto experience even better, so cryptocurrency trades won't execute right now.

1061471
Posted Jan 16, 2020 - 23:00 PST
This incident affected: Apps (iOS App, Web App, Android App) and Trading (Crypto Trading).