Bank Transfers Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 09:52 PDT
Investigating
We’re investigating reports that some customers are experiencing issues transferring money into Robinhood. We’re working to resolve this as soon as possible.
Posted Apr 25, 2022 - 09:37 PDT
This incident affected: Bank Transfers.