Web Options Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Oct 01, 2020 - 08:39 PDT
Investigating
Some customers are experiencing issues opening new Options positions on our Web app. We are working to resolve this issue as soon as possible.
Posted Oct 01, 2020 - 06:39 PDT
This incident affected: Apps (Web App).