Trading Issue
Incident Report for Robinhood
Resolved
Our systems have been fully restored and our app and web platforms are now functional. We apologize for the trouble and appreciate your patience as we worked to resolve this.
Posted Jun 18, 2020 - 10:08 PDT
Monitoring
We’ve taken swift action and are starting to see improvement. We’re still working to resolve the issue and will share more updates as we make progress.
Posted Jun 18, 2020 - 09:43 PDT
Update
We’re currently experiencing issues with our services and are investigating the issue.
Posted Jun 18, 2020 - 08:55 PDT
Investigating
We are experiencing issues with trading. We are working to resolve this issue as soon as possible.
Posted Jun 18, 2020 - 08:39 PDT
This incident affected: Overall System (Overall System), Trading (Equities Trading, Crypto Trading, Options Trading, Fractional Equities Trading), and Market Data, Order Status Updates, Bank Linking, Bank Transfers, Debit Card, Email Support.