Crypto Maintenance
Incident Report for Robinhood
Resolved
We're upgrading our systems to make the Crypto experience even better, so cryptocurrency trades won't execute right now.

1061471
Posted Oct 24, 2020 - 22:06 PDT
Monitoring
We're upgrading our systems to make the Crypto experience even better, so cryptocurrency trades won't execute right now.

1061471
Posted Oct 24, 2020 - 21:00 PDT
This incident affected: Trading (Crypto Trading).