Trading Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Oct 17, 2019 - 11:54 PDT
Investigating
We are experiencing issues with equities, options, and crypto trading. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted Oct 17, 2019 - 11:33 PDT
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading).