New Application Submission Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jan 06, 2020 - 15:42 PST
Investigating
Some users are experiencing issues submitting new applications on iOS and Android. We are working to resolve this issue as soon as possible.

1049960
Posted Jan 06, 2020 - 11:16 PST
This incident affected: Apps (iOS App, Web App).